
Notebook software training for SMART Board users level 1 learner workbook
Getting started
How does the SMART Board 
interact ive whiteboard work?
The SMART Board™ interactive whiteboard is very easy to use. If you can use a computer, you can use an 
interactive whiteboard.

The touch-sensitive display connects to your computer and projector to show your computer image. You 
can control applications from the display with your finger, write notes in digital ink and save your work to 
share later.
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Getting started
How does the SMART Board interactive whiteboard work?
The SMART Board interactive whiteboard is touch sensitive and operates as part of a system that includes 
a computer and a projector. 

 

•  The computer sends an image of an application to the projector

•  The projector casts the image onto the interactive whiteboard

•  The interactive whiteboard acts as both the monitor and input device, allowing you to control an 
application by simply touching the interactive whiteboard

It may help you to think of your interactive whiteboard the same way you think of your mouse or keyboard 
– it is an input device that enables you to control applications on your computer. 

Safety tips
•  You and your students should never look directly at the light beam from the projector. You (and your 

students) should always take a step (or even two) sideways before turning to face the class.

•  Tell your students not to touch the projector, as it can become extremely hot during normal operation

•  Don’t use a chair to increase a student’s reach. If your students can’t reach the top of the interactive 
whiteboard, lower it. You may need to remount a wall-mounted unit to a lower position. If your interactive 
whiteboard is mounted on a floor stand, lower it with the help of another adult.

•  Tell students not to run in the vicinity of the floor stand, as they may trip over the floor stand’s feet
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Your finger is your mouse
You can control applications on your computer from the interactive whiteboard. A 
press with your finger on a SMART Board interactive whiteboard is the same as a click 
with your mouse. You open an application the same way you do on your desktop 
computer, but instead of using your mouse to select and open files, just press or 
double-press the application icon with your finger. 

Orienting the interactive whiteboard will ensure the cursor is aligned with your finger 
press. 

The SMART Pen Tray
The SMART Pen Tray consists of four color-coded slots for pen tools and one slot for the eraser. Each slot 
has an optical sensor to identify when the pen tools and eraser have been picked up. You can write with the 
pen tool or with your finger, as long as a pen slot is empty. The technology in the pen tray is smart enough 
to know which tool was removed from its slot most recently. If you remove the eraser from its slot while you 
are still holding a pen tool, the pen tray will assume you want to erase. The lights above the tool slots 
indicate which tool was removed last. 

The pen-tray buttons
The pen tray has at least two pen-tray buttons. One button is used to launch the On-Screen Keyboard. The 
second button is used to make your next touch on the interactive whiteboard a right-click. Some interactive 
whiteboards have a third button. The third button is used to access the Help Center quickly. 

The pen tools
The SMART Board interactive whiteboard comes with four pen tools, which are black, red, green and blue, 
and one eraser. Although you do not need to use the pen tools to write on your interactive whiteboard, they 
do make writing more intuitive. Pick up a pen tool from the SMART Pen Tray and begin writing. To erase 
your digital ink, remove the eraser from the pen tray and move it in a smooth motion over your notes. The 
notes will disappear.

Pen-tray buttons
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Getting started
The On-Screen Keyboard
This on-screen, virtual keyboard eliminates the need for an attached physical keyboard, as you can use its 
many views to enter typed text. There are several available keyboard views, including the Classic, Write, 
Simple, Simple Capitals, Number Pad and Shortcut view.

To open the keyboard, press the SMART Board icon in the notification area and select Keyboard. 
Alternatively, press the Keyboard button on your SMART Board interactive whiteboard pen tray. 

Type or edit text in any application without leaving the interactive whiteboard.

Press the Keyboard button on the pen tray to launch the On-Screen Keyboard.

Classic view
Press the virtual keys to type text, then press the Send button to place the text into the active dialog box or 
application. You can type into any application, whether it’s Ink Aware or not. 

Select a
view

You can use the
keyboard to

complete online
forms or to

enter text in any
application.
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Preview pane 
Press the double-arrow button to open the preview pane. When the preview pane is open, you can type an 
entire word or sentence before sending any information to an application. When you are finished typing, 
pressing the Send button will send your text to the active application.

Simple views
Teachers who are teaching students who are just learning the alphabet, or who are not yet familiar with a 
standard keyboard layout, will appreciate the two simple views available – Simple and Simple Caps. In both 
of these views, the letters are arranged in alphabetical order, followed by digits 0 through 9. 

The right mouse button
Press the right mouse button on the pen tray to have your next press on the 
screen recognized as a right-click. 

A graphic in the bottom right of your screen will appear to remind you that your 
next press will be registered as a right-click. 

TIP: Instead of pressing the right mouse button, press and hold on the area of the screen where you 
would like to make a right-click. After a few seconds of pressing and holding the area, the right-click menu 
will appear.

Double arrow buttonPreview pane
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Getting started
Orienting your SMART Board interactive whiteboard
Orientation ensures your touch is registered 
accurately when you are using the interactive 
whiteboard. 

If you are touching an icon and your cursor appears 
somewhere other than where you are pressing, try 
orienting the interactive whiteboard. After orientation, 
your cursor should appear wherever you are touching 
the interactive whiteboard.

To launch the Orient function, press and hold the 
keyboard button and the right mouse button 
simultaneously until the Orientation screen appears.

The Help button
If the pen tray features a help button, press it to launch the Help and Support for 
Your SMART Board Interactive Whiteboard dialog box. The dialog box provides 
one-touch access to information that will help you answer almost any question 
relating to your SMART product. 

The Orientation screen
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The Ready Light 
Your SMART Board interactive whiteboard includes a Ready Light that indicates the status of your 
interactive whiteboard. 

Writing notes
Make notes or drawings by removing a pen tool from the pen tray and writing on the surface of the 
interactive whiteboard.

The Digital Ink Layer
When you remove a pen tool from the pen tray, a border appears around your desktop, and the 
Floating Tools toolbar launches. If it does not launch immediately, press the SMART Board™ 
icon located in the Windows Notification Area at the bottom right of your screen. Choose Show 
Floating Tools... from the menu.

Color of Ready Light Status

Not lit •  The interactive whiteboard does not have power

•  Check the USB cable connections

Solid green •  The interactive whiteboard is successfully communicating with the 
SMART Board software on the computer

Flashing green •  The SMART Board driver isn’t installed. Or if it’s installed, it isn’t running. 
Verify that the driver is installed, and if it isn’t, install it. 

•  If the Ready Light continues to flash green, you may want to contact your 
support representative for assistance

Solid red •  The interactive whiteboard has power, but it is not communicating with the 
computer

•  During the initial powering up or power reset, you will see the Ready Light 
turn red for a moment

•  This brief red illumination is normal

Flashing amber •  Occurs only when you are updating firmware using SMART’s Firmware 
Flashing Wizard

•  This is normal

Solid amber •  Problem state

•  Try resetting the interactive whiteboard by disconnecting and then 
reconnecting the USB cable at the interactive whiteboard end
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Getting started
The border indicates the Digital Ink Layer is in place, and you can write on the desktop just as you would 
write on a transparent sheet. The Digital Ink Layer and its visible border remain in place until all pen tools 
and the eraser have been returned to the pen tray and you touch the board.  

Your first touch on the board, after returning all the pen tray tools, will bring up 
a menu with options for capturing your writing. If you wish to hide this menu in 
the future, click Ink Layer Options... and select the Close ink layer with 
pointer checkbox. 

To save an image of the screen on which you were writing into a new Notebook 
page, choose Save Ink. To clear the writing but keep the Digital Ink Layer in 
place, choose Clear Ink. To remove the Digital Ink Layer and clear the writing, 
choose Close Ink Layer.

Restoring your notes and drawings
If you accidentally clear your ink, you can restore your notes and drawings by pressing 
the Click here to restore ink icon, located in the lower right of the screen. You can then 
use the Capture writing button to save your notes.

Close 
Digital Ink 
Layer

Capture 
writing

Clear 
writingBorder

Floating 
Tools toolbar
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If you do not see the Click here to restore ink message or don’t reach it before it 
disappears, press the Undo button in the Floating Tools toolbar to restore your notes 
and drawings.

Advanced feature – Capturing your notes and drawings
If you wish to capture a specific area of your screen, press the SMART Board icon located in the Windows 
Notification Area at the bottom right of your screen. Choose Other SMART Tools > Screen Capture 
Toolbar... from the menu to launch the Screen Capture Toolbar.

To capture an area of your desktop, follow these steps:

  1  Press the Area Capture button on the Floating 
Tools toolbar. The Area Capture tool will appear.

  2  Press on any corner of the area you wish to 
capture and, continuing to press, drag the 
selection box until it surrounds the entire area

  3  Release your press and your selection will be 
captured as a graphic into Notebook software. If 
Notebook software is not already open, it will open automatically when you capture a portion of your 
screen. Save your Notebook file by selecting File > Save.

Undo 
button

Area Capture 
button

Window
Capture 
button

Screen 
Capture 
button

Freehand 
Capture 
button
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Review questions: Getting started
  1  Name the three components required to operate a SMART Board interactive whiteboard.

  2   How do you know when the interactive whiteboard is ready to be used?

  3  Circle the pen-tray button that launches the On-Screen Keyboard. 

  4  Describe one way to begin the orientation process.

  5  How do you right-click on the interactive whiteboard?

  6  Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.
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Getting started
Review answers: Getting started
  1  Name the three components required to operate a SMART Board interactive whiteboard.

Interactive whiteboard
Computer
Projector

  2   How do you know when the interactive whiteboard is ready to be used?

The Ready Light is a steady green. 

  3  Circle the pen-tray button that launches the On-Screen Keyboard. 

  4  Describe one way to begin the orientation process.

Press and hold the keyboard button and the right-mouse button on the pen tray simultaneously.

  5  How do you right-click on the interactive whiteboard?

Press the right mouse button on the pen tray to have your next press on the interactive whiteboard 
recognized as a right-click. 

  6  Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.

Press the Undo button on the Floating Tools toolbar.
Press the Click here to restore ink icon in the lower right of the screen.
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Hands-on practice: Basic functionality
Your school or company has just moved one of your SMART Board interactive whiteboards into a new room 
because you were unable to access the Internet from the old location. You will be the first person to use it 
in the new environment and will be showing everyone how to use it and the Internet together.

You have learned through experience that whenever a piece of technology gets moved, it’s a good idea to 
test it before you deliver a lesson or presentation. The computer, interactive whiteboard and projector 
appear to be working properly when you turn everything on. However, when you double-press the Internet 
browser icon on your desktop, your cursor appears a few inches away from your finger press.

Orienting your SMART Board interactive whiteboard
You remember that when the projector or interactive whiteboard moves location, you should orient the 
board. This action will tell the computer where the image of the desktop is being displayed on the surface 
of the interactive whiteboard.

  1  To orient the interactive whiteboard, press and hold the keyboard button and the right mouse button 
simultaneously until the Orientation screen appears

  2  Begin the orientation process at the upper-left corner of the Orientation screen. Press your finger or 
pen tool firmly on the center of each cross in the order indicated by the white, diamond-shaped 
graphic.

NOTE: The point is registered when you remove your finger, not when you first touch the       
Orientation screen.

Pen-tray buttons

The Orientation screen
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Getting started
Testing basic functionality
It’s a good idea to test the basic functionality of your interactive whiteboard to ensure all the applications you 
will be using to deliver your lesson or presentation are working properly.

  1  Using your finger, double-press on the Internet browser icon (e.g., Internet Explorer®) to launch the 
Internet

  2  Press the On-Screen Keyboard button on the SMART Pen Tray

  3  Press once inside your Internet browser’s address bar to select the website address 

  4  Using the On-Screen Keyboard, type www.google.com

NOTE: The On-Screen Keyboard is a single point of contact. Touch-typing or keystroke combinations 
are not possible.

  5  Press the Go button beside your Internet browser’s address bar
14



Notebook software training for SMART Board users level 1 learner workbook
  6  Pick up a pen tool from the pen tray. The Digital Ink Layer will appear, as shown by a visible border 
around the desktop. The border indicates you can write on the desktop, and it remains in place until 
you close it or navigate to a different application.

  7  Using a pen tool, circle the browser’s Back button

  8  Return the pen tool to the pen tray, and touch the interactive whiteboard once. Choose Clear ink from 
the menu to erase your ink. Press the Click here to restore ink icon at the bottom right of the screen 
to bring the circle back.

You have now confirmed that you can clear your notes by touching the interactive whiteboard, then 
restore your notes by pressing the Clear here to restore ink icon.

  9  To ensure you will be able to capture and save important information for a future lesson or 
presentation, launch the Screen Capture toolbar by pressing the SMART Board icon located in the 
Windows Notification Area at the bottom right of your screen. Choose Other SMART Tools... > 
Screen Capture Toolbar... from the menu.

  10  Press the Area Capture button

Digital Ink Layer
border

Area Capture 
button
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Getting started
11  Press the interactive whiteboard and, without releasing pressure, drag the selection box using your 
finger to outline the circle around your browser’s Back button. Release your press to capture the 
image to Notebook software. 

NOTE: Notebook software will open automatically, and your notes and background will be saved to a 
new Notebook page.

12  Clear the circle from your browser’s Back button

13  Select the unsaved Notebook file from the taskbar to view your captured image in Notebook software. 
Select File > Save to save your notes for future reference.
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Working with Ink 
Aware applications
What is Ink Aware?
When software is Ink Aware, you can write and draw directly into the active file. For example, if you write a 
note or draw something while using Microsoft® Word software, you can save your Word file and your notes 
will be visible the next time you open it.
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Working with Ink Aware applications
How do Ink Aware applications work? 
Ink Aware applications recognize which area of the software is the active work area and which area is used 
for buttons and toolbars.

Which applications are Ink Aware? 

This section will focus on the most commonly used applications – Microsoft Word, Excel and PowerPoint.

Microsoft 
Office

Microsoft Word, Microsoft Excel®, OpenOffice Calc, OpenOffice Writer

Graphic 
applications

CorelDRAW®, OpenOffice DRAW, Microsoft Imaging, Corel® Grafigo™ 2, Microsoft 
Paint®, ArcView, Autodesk® DWF Composer 2.0, Volo® View Express

Presentation 
applications

Microsoft PowerPoint®, Corel Presentations™, Microsoft Office Live Meeting, 
Microsoft NetMeeting® 2.0/2.1/3, OpenOffice Impress 

Other 
applications

AutoCAD®, AutoVue™ Professional, Microsoft Windows® Journal, Microsoft Office 
OneNote®, Microsoft Visio®, Adobe® Acrobat® Professional 6.0/7.0/8.0 

Buttons and toolbars 
area

Active work area}
}
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Microsoft Word and Excel software
When using Word or Excel software with your SMART Board™ interactive whiteboard, you will notice four 
buttons. They may be integrated with the application toolbar or separated as a floating toolbar.

If you do not see this toolbar, select View > Toolbars > SMART Aware Toolbar.

Word example: Pressing the Insert as Image button

Before you press the button, the image is not part of 
the Microsoft Word document. It can only be seen 
on the interactive whiteboard.

Press the button and the image becomes part of 
the Microsoft Word document.

Excel example: Pressing the Insert as Text button

Before you press the button, the image is not part of 
the Excel software file. It can only be seen on the 
interactive whiteboard.

Press the button and the text becomes part of the 
Excel software file.

Automatically insert the 
drawing as an image

Insert drawings or 
writing as an image 
directly into document

Convert writing as typed text 
directly into document. Text will 
appear at the cursor point in the 
pen color used.

Save a screen 
capture in Notebook 
software
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Microsoft PowerPoint software
When you work with PowerPoint software in Normal view on an interactive whiteboard, you can save your 
hand-written notes as images or text and save screen captures to SMART Notebook software, just as you 
can when using Microsoft Word or Excel software. Ink Aware features can be accessed through the Aware 
Floating Tools, which launches when you pick up a pen tool to write notes or make drawings. Note that you 
will only see this toolbar when you are in Normal view.

When you present with PowerPoint software on an interactive whiteboard, you can also save your notes as 
images and save screen captures to SMART Notebook software. Ink Aware applications can be accessed 
through the Slide Show toolbar, which launches when you enter Slide Show view. Note that you will only 
see this toolbar when you are in Slide Show view. 

TIP: You can go to the next slide of a PowerPoint software presentation by pressing twice on the 
interactive whiteboard, making the second press to the right of the first. To go to the previous slide, make 
the second press to the left of the first. 

 Aware Floating Tools

Save a screen 
capture to 
SMART 
Notebook 
software

Convert your writing into 
typed text

Insert drawings or
writing as an image

     Slide Show toolbar

Go to the next 
slide in your 
presentation

Open the Command menuGo to the previous
slide in your
presentation
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The Command menu
Press the center button on the Slide Show toolbar to launch the Command menu.

PowerPoint Commands submenu

Settings submenu

TIP: Use the Black/Unblack Screen command when you would like to draw the attention of your class 
or audience away from the screen and to the presenter. Press twice in rapid succession anywhere on 
the screen to resume your slide show exactly where you left off. 

Capture an image of the current 
slide to SMART Notebook software

Save your notes directly 
into your PowerPoint        
presentation file

Delete your notes from the page
Add an additional slide to your 
presentation

Launch the PowerPoint Commands 
submenu

Launch the Settings submenu

Launch the Floating Tools toolbar 

End the slide show 

Skip to any slide in your presentation

Make the screen black

Print the slide on your default printer 

Open the PowerPoint software menu

Deselect to advance slides 
with a single press

Deselect if you don’t wish to 
save your drawings at the end 
of the show

Deselect for an opaque toolbar
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SMART Floating Tools toolbar
The Windows Operating System taskbar and notification area are hidden when you are presenting a       
PowerPoint software slide show. You can still launch the Floating Tools toolbar by selecting SMART Float-
ing Tools from the Command menu. 

TIPS:

  1  Use the Ink Aware toolbar buttons to convert your notes directly in Microsoft Word and Excel 
software

  2  The Slide Show toolbar in PowerPoint software allows you to control a PowerPoint software 
presentation while you are at your SMART Board interactive whiteboard 

  3  You can launch the Floating Tools toolbar during a PowerPoint software slide show by selecting 
Slide Show Toolbar > Command Menu > SMART Floating Tools
22
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Review questions: Ink Aware
  1  Describe the function of each of the buttons on the Ink Aware toolbar that appears in Microsoft 

Word software.

  2  Describe how to insert digital ink as text into a selected cell of an Excel software spreadsheet.

  3  Describe how to save writing on a PowerPoint slide into SMART Notebook software when in Slide 
Show view. 

  4  Describe how you would save your notes and drawings to PowerPoint software files.
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Review answers: Ink Aware 
  1  Describe the function of each of the buttons on the Ink Aware toolbar that appears in Microsoft 

Word software.

•  Insert as Image: Inserts notes as an image into the document or spreadsheet

•  Insert as Text: Converts notes into typed text and inserts them into the document or 
spreadsheet

•  Capture to SMART Notebook: Captures the visible active work area into SMART Notebook 
software

•  Settings allows drawings to be automatically inserted into the document as an image

  2  Describe how to insert digital ink as text into a selected cell of an Excel software spreadsheet.

To save digital ink as text, press the Insert as Text button on the Ink Aware toolbar 

  3  Describe how to save writing on a PowerPoint slide into SMART Notebook software.

Press the center button on the three-button Slide Show toolbar and select Capture to Notebook. 
Both the slide and the notes will be captured as an image to SMART Notebook software. 

  4  Describe how you would save your notes and drawings to PowerPoint software files.

Press the center button on the three-button Slide Show toolbar and select Insert Drawing as 
Image. 

If you do not save your notes and move forward to the next slide, you will be prompted to save 
your notes when you end the slide show. This option can be deselected in the Settings submenu. 
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Hands-on practice: 
Ink Aware and Microsoft Word software in the classroom

Before you start
Before you begin your class, ensure that your computer is turned on and the SMART Board interactive 
whiteboard is connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows operating 
system.

Preparation
Create a short, two-question quiz. In a real-world example, you would open a quiz prepared in advance.

  1  Open a blank document in Word

  2  Type a mathematical equation using your computer’s keyboard – for example, 13 x 7 =. Press the 
Enter key several times to give your students space to show their work.

  3  Type Complete the following sentence with either “quick” or “quickly.” Press the Enter key twice, then 
type When excited, she spoke very

Using Ink Aware in the classroom
Your class has just completed the quiz you created in Word. Now you would like to review the answers as 
a group.

  1  Use a pen tool from the SMART Pen Tray to demonstrate how to arrive at the correct answer on the 
interactive whiteboard. Put the pen tool back in the pen tray, and press the Insert as Image button to 
add the answer to your Word file.
25
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  2  Move to the next quiz question. Discuss with your class when to use the word quick versus quickly in 
the sentence.

  3  Touch the interactive whiteboard to place the cursor at the end of the sentence

  4  Use a pen tool from the pen tray to write the correct answer on the interactive whiteboard

  5  Press the Insert as Text button to convert the correct answer to text. The text will appear at the 
cursor point in the pen color used.

  6  Save your document in Word. Now you can e-mail or print copies and distribute the answers to your 
students. 
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Hands-on practice:
Ink Aware and Microsoft Excel software in the office

Before you start
Before you begin your class, ensure that your computer is turned on and the SMART Board interactive 
whiteboard is connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows operating 
system.

Preparation
  1  Open a blank spreadsheet in Excel software

  2  Type Hotel in cell A2 on your computer’s keyboard

  3  Type Flight in cell A3

  4  Type 1000 in cell B3

Using Ink Aware in the office
Assume you and your colleagues are attending a conference in the near future. As a group, you prepared 
a travel request outlining the anticipated expenses. This request will be presented to the accounting 
department for approval.

  1  One group member states the hotel will cost $150 per night. Press the cell in the spreadsheet to 
highlight the cell in which the cost will be placed. Pick up a pen tool from the SMART Pen Tray and 
write 150 on the interactive whiteboard.
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Working with Ink Aware applications
  2  Another group member declares the corporate rate for the hotel is only $115 per night. Put the pen 
tool back in the pen tray and press once on the interactive board to remove 150. Then, press the cell 
in the spreadsheet into which the new cost will be placed. Write 115. 

  3  Press the Insert as Text button to add the hotel rate into the highlighted cell. Your text is inserted into 
the spreadsheet and will appear in the pen color used.

  4  Finally, your team lead suggests that you get a minimum of three price quotes for the flight. Circle the 
flight cost in cell B3 and write Get quote. Press the Insert as Image button to insert your note as an 
image into your spreadsheet.

  5  Save your spreadsheet as an Excel software file. Now you can update the travel request with your 
group’s notes and e-mail it to the accounting department for approval.
28
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Hands-on practice: Using Microsoft PowerPoint software
on a SMART Board interactive whiteboard

Before you start
Before you begin, ensure that your computer is turned on and the SMART Board interactive whiteboard is 
connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows operating 
system.

Preparation
Assume your supervisor has requested a brief presentation on the topic of productivity in the office. The 
preliminary work on your presentation requires you to incorporate feedback and suggestions from your 
colleagues. The final presentation will be presented to your supervisor.

A sample PowerPoint software file is available at www.smarttech.com/media/trainingcenter/
samplepresentation.ppt for this lesson. If this file opens in your Web browser, save it to your desktop and 
then reopen it. 

Alternatively, open an existing PowerPoint software presentation saved on your computer. The steps in this 
hands-on practice will still be applicable to you when using your own presentation with an interactive 
whiteboard.

Presenting on an interactive whiteboard
  1  Select View > Slide Show to begin your presentation. The Slide Show toolbar automatically appears 

so you can navigate between slides.

  2  Press the Next Slide button on the Slide Show toolbar to move forward one slide. Then press the 
Previous Slide button to move back one slide.

TIP: You can go to the next slide of a PowerPoint software presentation by pressing twice on the 
interactive whiteboard, making the second press to the right of the first. To go to the previous slide, make 
the second press to the left of the first.

Press twice. A second press to the left will move                             
to the previous slide.

Press twice. A second press to the right will move                          
to the next slide.
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Working with Ink Aware applications
  3  Advance the slide show by pressing twice on the interactive whiteboard, remembering to make the 
second press to the right of the first

  4  For emphasis, you want to draw your audience’s attention to the items listed on your PowerPoint 
slide. Pick up a pen tool from the SMART Pen Tray and place a check mark beside each point as you 
discuss it with your colleagues.

  5  After the discussion, you decide to remove the check marks. Return the pen tool to the pen tray and 
touch the interactive whiteboard once with your finger to clear your notes.

  6  Use the Slide Show toolbar, or press twice on the interactive whiteboard to advance to the next slide

  7  Your colleagues take an interest in the statistics you referenced on your PowerPoint slide and ask you 
to send them the source material. Record their request as a note to remind yourself to get back to 
them later. Pick up a pen tool from the pen tray and write send source material. 

  8  Return the pen tool to the pen tray
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  9  Since you want to follow up on your note, but you don’t want to save it as a permanent part of your 
presentation, press the Menu button on the Slide Show toolbar and select Capture to Notebook 
from the drop-down menu. SMART Notebook software will open automatically and an image of your 
PowerPoint slide with your written reminder will be inserted into a new SMART Notebook file.

10  Now that your reminder has been captured to SMART Notebook software, press once on the 
interactive whiteboard to erase your note from your PowerPoint software presentation. Advance to the 
next slide.

11  The next slide in your presentation requires feedback from your colleagues. Pick up a pen tool from 
the pen tray, and record their suggestions. 

  12  Oops! After putting the pen tool back in the pen tray, you accidentally erased your notes. What if you 
had wanted to save that information?

Before you pick up the pen tool again, press the Click here to restore writing icon that appears in 
the  bottom-right corner of the screen. Your notes will reappear on the slide.

New SMART 
Notebook file
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13  You are ready to end your presentation. Press the Menu button on the Slide Show toolbar and select 
End Show from the drop-down menu. Select Yes in the SMART Aware message box to add your 
notes to your PowerPoint software presentation.

14  Select File > Save to save your notes into your original presentation, or select File > Save As to save 
to a new PowerPoint software file. Close your presentation.

15  Now select the unsaved SMART Notebook file created earlier in the lesson. Select File > Save to 
save your notes for future reference.

TIP: If the Click here to restore writing icon disappears from the interactive whiteboard, don’t worry. 
Click the Menu button on the Slide Show toolbar and select Restore Drawing.
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Additional resources
What’s next?

SMART supports your use of SMART products with a number of resources, including free training materials 
on the SMART website and a special online community for educators. 
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Additional resources 
SMART’s training center 
SMART’s training center is where you’ll find additional training resources and support, including free training 
materials and online training sessions to help you effectively use the SMART products. Visit 
www.smarttech.com/trainingcenter.

Free training materials
The free training materials available from SMART’s training center will help you gain practical experience 
with SMART products in addition to developing skills to deliver lesson activities on the SMART Board 
interactive whiteboard.

Quick references are simple one- or two-page overviews of the features of SMART Notebook software and 
other SMART products. They are formatted for printing, so you can keep them beside your computer or 
SMART Board interactive whiteboard to remind you of how to use some of the features. 

Free online training sessions
SMART online training sessions are 30- to 45-minute computer and telephone conferences that offer a 
quick, no-cost overview of the basics of working with SMART products. Each session is led by a SMART 
trainer who uses SMART products every day. SMART’s online training sessions are useful as a review and 
they give you an opportunity to ask questions.

The following are a few of the online sessions that SMART provides:

•  SMART Board interactive whiteboard basics 

•  SMART Notebook software basics

•  Senteo™ interactive response system

•  Setting up your SMART Board interactive whiteboard

•  SynchronEyes™ classroom management software

Visit http://smarttech.com/trainingcenter/online/index.asp for a full listing of online sessions. 

We are always developing new, free online training offerings. Visit SMART’s training center often to learn 
about the latest sessions. 
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SMART support
SMART’s support site offers a variety of product support options. Visit SMART’s support site to download 
software, including SMART Notebook software, Senteo assessment software and SynchronEyes 
classroom management software. You’ll find installation and user's guides, how-to and troubleshooting 
articles, solutions for your SMART product and answers to your questions. You can also use SMART’s 
support site to contact technical support and to register your SMART product.

Visit www.smarttech.com/support.

SMART’s software downloads
The latest versions and upgrades for SMART software are available on the software downloads section of 
www.smarttech.com. You can download SMART Notebook software and free trials for an assortment of 
other useful  software at http://www2.smarttech.com/st/en-US/Support/Downloads/default.htm.

SMART’s education solutions website
SMART’s education solutions website is an online community where educators can share resources and 
ideas with other educators worldwide. The education solutions website is where you will find the following 
resources:

•  Free learning resources for use with SMART products, including content collections, software 
applications and website resources

•  Hundreds of SMART Notebook software lesson activities correlated to state and provincial 
curriculum standards

•  Professional development programs to reward, recognize and support educators

•  Research on the effectiveness of SMART Board interactive whiteboards in learning 
environments

•  Advice for educators about using SMART products, integrating peripherals, mastering grant 
writing and evaluating technology
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SMART’s Teachers’ Hub
SMART’s Teachers’ Hub – it has all the resources you need to get started.

Visit  www.education.smarttech.com/Hub. 

SMART accredited titles
Find a wealth of multimedia content and software to enhance your classroom environment on SMART’s 
education solutions website. SMART accredits education titles based on their level of compatibility with 
SMART Board interactive whiteboards and SMART Notebook collaborative learning software.

SMART offers three levels of accreditation.

Ready This is the basic accreditation level for a software or content product, indicating that 
SMART has approved the title for use with its products.

Enabled Products at this level meet the requirements of the Ready level and are also 
integrated with SMART Board Tools. The integration enhances interactivity because it takes 
advantage of a digital ink feature called SMART Ink Aware.

Select Software and content products at this level meet all requirements of the Enabled level 
and are specifically designed for use on SMART Notebook software.

To access the list of accredited software programs and details on these programs, go to SMART’s 
education solutions website and select Educator resources > SMART accredited software. Accredited 
software is categorized by subject and grade level, enabling you to quickly find software that meets your 
needs. 
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Session feedback

Please take a moment to complete this questionnaire in as much detail as possible. Your feedback is an integral part of 
improving our future training sessions. All comments are welcome.

Please choose the value that best represents your satisfaction level with the following, from the scale provided:

1 – Very dissatisfied     2 – Dissatisfied     3 – Satisfied     4 – Very satisfied

Your overall satisfaction with the following:

Please help us to improve our sessions by providing specific feedback on any parts of the session.  This additional feedback 
will help us design future and reshape current SMART training offerings to better meet customer needs.

Thank you for taking the time to respond. We appreciate your feedback. If there are any questions or concerns not 
addressed here, please speak to your trainer or e-mail training@smarttech.com.

 1         2         3         4        n/a 

Registration and booking process

Structure and design of the course

Pace of the session

Relevance of the course content

Knowledge you gained from the session

Learning resources provided

Hands-on activities

Effectiveness of the presenter

mailto:training@smarttech.com

	How does the SMART Board interactive whiteboard work?
	Your finger is your mouse
	The SMART Pen Tray

	The On-Screen Keyboard
	The right mouse button
	Orienting your SMART Board interactive whiteboard

	The Help button
	The Ready Light
	Writing notes
	1 Press the Area Capture button on the Floating Tools toolbar. The Area Capture tool will appear.
	2 Press on any corner of the area you wish to capture and, continuing to press, drag the selection box until it surrounds the entire area
	3 Release your press and your selection will be captured as a graphic into Notebook software. If Notebook software is not already open, it will open automatically when you capture a portion of your screen. Save your Notebook file by selecting File > ...
	1 Name the three components required to operate a SMART Board interactive whiteboard.
	2 How do you know when the interactive whiteboard is ready to be used?
	3 Circle the pen-tray button that launches the On-Screen Keyboard.
	4 Describe one way to begin the orientation process.
	5 How do you right-click on the interactive whiteboard?
	6 Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.
	1 Name the three components required to operate a SMART Board interactive whiteboard.
	2 How do you know when the interactive whiteboard is ready to be used?
	3 Circle the pen-tray button that launches the On-Screen Keyboard.
	4 Describe one way to begin the orientation process.
	5 How do you right-click on the interactive whiteboard? Press the right mouse button on the pen tray to have your next press on the interactive whiteboard recognized as a right-click.
	6 Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.

	Hands-on practice: Basic functionality
	1 To orient the interactive whiteboard, press and hold the keyboard button and the right mouse button simultaneously until the Orientation screen appears
	2 Begin the orientation process at the upper-left corner of the Orientation screen. Press your finger or pen tool firmly on the center of each cross in the order indicated by the white, diamond-shaped graphic. Note: The point is registered when you r...
	1 Using your finger, double-press on the Internet browser icon (e.g., Internet Explorer®) to launch the Internet
	2 Press the On-Screen Keyboard button on the SMART Pen Tray
	3 Press once inside your Internet browser’s address bar to select the website address
	4 Using the On-Screen Keyboard, type www.google.com Note: The On-Screen Keyboard is a single point of contact. Touch-typing or keystroke combinations are not possible.
	5 Press the Go button beside your Internet browser’s address bar
	6 Pick up a pen tool from the pen tray. The Digital Ink Layer will appear, as shown by a visible border around the desktop. The border indicates you can write on the desktop, and it remains in place until you close it or navigate to a different appli...
	7 Using a pen tool, circle the browser’s Back button
	8 Return the pen tool to the pen tray, and touch the interactive whiteboard once. Choose Clear ink from the menu to erase your ink. Press the Click here to restore ink icon at the bottom right of the screen to bring the circle back. You have now conf...
	9 To ensure you will be able to capture and save important information for a future lesson or presentation, launch the Screen Capture toolbar by pressing the SMART Board icon located in the Windows Notification Area at the bottom right of your screen...
	10 Press the Area Capture button
	11 Press the interactive whiteboard and, without releasing pressure, drag the selection box using your finger to outline the circle around your browser’s Back button. Release your press to capture the image to Notebook software. Note: Notebook soft...
	12 Clear the circle from your browser’s Back button
	13 Select the unsaved Notebook file from the taskbar to view your captured image in Notebook software. Select File > Save to save your notes for future reference.
	Working with Ink Aware applications
	What is Ink Aware?


	How do Ink Aware applications work?
	Which applications are Ink Aware?

	Microsoft Word and Excel software
	Microsoft PowerPoint software
	1 Use the Ink Aware toolbar buttons to convert your notes directly in Microsoft Word and Excel software
	2 The Slide Show toolbar in PowerPoint software allows you to control a PowerPoint software presentation while you are at your SMART Board interactive whiteboard
	3 You can launch the Floating Tools toolbar during a PowerPoint software slide show by selecting Slide Show Toolbar > Command Menu > SMART Floating Tools
	1 Describe the function of each of the buttons on the Ink Aware toolbar that appears in Microsoft Word software.
	2 Describe how to insert digital ink as text into a selected cell of an Excel software spreadsheet.
	3 Describe how to save writing on a PowerPoint slide into SMART Notebook software when in Slide Show view.
	4 Describe how you would save your notes and drawings to PowerPoint software files.
	1 Describe the function of each of the buttons on the Ink Aware toolbar that appears in Microsoft Word software.
	2 Describe how to insert digital ink as text into a selected cell of an Excel software spreadsheet. To save digital ink as text, press the Insert as Text button on the Ink Aware toolbar
	3 Describe how to save writing on a PowerPoint slide into SMART Notebook software. Press the center button on the three-button Slide Show toolbar and select Capture to Notebook. Both the slide and the notes will be captured as an image to SMART Noteb...
	4 Describe how you would save your notes and drawings to PowerPoint software files. Press the center button on the three-button Slide Show toolbar and select Insert Drawing as Image. If you do not save your notes and move forward to the next slide, y...

	Hands-on practice: Ink Aware and Microsoft Word software in the classroom
	1 Open a blank document in Word
	2 Type a mathematical equation using your computer’s keyboard – for example, 13 x 7 =. Press the Enter key several times to give your students space to show their work.
	3 Type Complete the following sentence with either “quick” or “quickly.” Press the Enter key twice, then type When excited, she spoke very
	1 Use a pen tool from the SMART Pen Tray to demonstrate how to arrive at the correct answer on the interactive whiteboard. Put the pen tool back in the pen tray, and press the Insert as Image button to add the answer to your Word file.
	2 Move to the next quiz question. Discuss with your class when to use the word quick versus quickly in the sentence.
	3 Touch the interactive whiteboard to place the cursor at the end of the sentence
	4 Use a pen tool from the pen tray to write the correct answer on the interactive whiteboard
	5 Press the Insert as Text button to convert the correct answer to text. The text will appear at the cursor point in the pen color used.
	6 Save your document in Word. Now you can e-mail or print copies and distribute the answers to your students.

	Hands-on practice: Ink Aware and Microsoft Excel software in the office
	1 Open a blank spreadsheet in Excel software
	2 Type Hotel in cell A2 on your computer’s keyboard
	3 Type Flight in cell A3
	4 Type 1000 in cell B3
	1 One group member states the hotel will cost $150 per night. Press the cell in the spreadsheet to highlight the cell in which the cost will be placed. Pick up a pen tool from the SMART Pen Tray and write 150 on the interactive whiteboard.
	2 Another group member declares the corporate rate for the hotel is only $115 per night. Put the pen tool back in the pen tray and press once on the interactive board to remove 150. Then, press the cell in the spreadsheet into which the new cost will...
	3 Press the Insert as Text button to add the hotel rate into the highlighted cell. Your text is inserted into the spreadsheet and will appear in the pen color used.
	4 Finally, your team lead suggests that you get a minimum of three price quotes for the flight. Circle the flight cost in cell B3 and write Get quote. Press the Insert as Image button to insert your note as an image into your spreadsheet.
	5 Save your spreadsheet as an Excel software file. Now you can update the travel request with your group’s notes and e-mail it to the accounting department for approval.

	Hands-on practice: Using Microsoft PowerPoint software on a SMART Board interactive whiteboard
	1 Select View > Slide Show to begin your presentation. The Slide Show toolbar automatically appears so you can navigate between slides.
	2 Press the Next Slide button on the Slide Show toolbar to move forward one slide. Then press the Previous Slide button to move back one slide.
	3 Advance the slide show by pressing twice on the interactive whiteboard, remembering to make the second press to the right of the first
	4 For emphasis, you want to draw your audience’s attention to the items listed on your PowerPoint slide. Pick up a pen tool from the SMART Pen Tray and place a check mark beside each point as you discuss it with your colleagues.
	5 After the discussion, you decide to remove the check marks. Return the pen tool to the pen tray and touch the interactive whiteboard once with your finger to clear your notes.
	6 Use the Slide Show toolbar, or press twice on the interactive whiteboard to advance to the next slide
	7 Your colleagues take an interest in the statistics you referenced on your PowerPoint slide and ask you to send them the source material. Record their request as a note to remind yourself to get back to them later. Pick up a pen tool from the pen tr...
	8 Return the pen tool to the pen tray
	9 Since you want to follow up on your note, but you don’t want to save it as a permanent part of your presentation, press the Menu button on the Slide Show toolbar and select Capture to Notebook from the drop-down menu. SMART Notebook software will...
	10 Now that your reminder has been captured to SMART Notebook software, press once on the interactive whiteboard to erase your note from your PowerPoint software presentation. Advance to the next slide.
	11 The next slide in your presentation requires feedback from your colleagues. Pick up a pen tool from the pen tray, and record their suggestions.
	12 Oops! After putting the pen tool back in the pen tray, you accidentally erased your notes. What if you had wanted to save that information?
	13 You are ready to end your presentation. Press the Menu button on the Slide Show toolbar and select End Show from the drop-down menu. Select Yes in the SMART Aware message box to add your notes to your PowerPoint software presentation.
	14 Select File > Save to save your notes into your original presentation, or select File > Save As to save to a new PowerPoint software file. Close your presentation.
	15 Now select the unsaved SMART Notebook file created earlier in the lesson. Select File > Save to save your notes for future reference.
	Basics for SMART Notebook software
	What is SMART Notebook software?


	Using Notebook software for the first time
	SMART Notebook software menu bar
	SMART Notebook software toolbar

	Side tabs
	Page Sorter tab
	Gallery tab
	1 Click inside the search field
	2 Type a keyword related to the type of object(s) you are looking for
	3 Click the search button to display your results
	1 Click My Content and click the page drop- down menu arrow
	2 From the drop-down menu, click Add to My Content to launch the Add to My Content dialog box
	3 Browse to the file you would like to add
	4 Click the file you would like to add
	5 Click the Open button

	Attachments tab
	Sharing your SMART Notebook file

	The Properties tab
	1 What are the four tabs in SMART Notebook software?
	2 Describe how to move an object from one SMART Notebook page to another.
	3 How do I add a blank page to SMART Notebook software?
	4 Why would you change the location of the tabs or toolbar located in the SMART Notebook software?
	5 Why would you use the Attachments tab?
	1 What are the four tabs in SMART Notebook software?
	2 Describe how to move an object from one SMART Notebook page to another.
	3 How do I add a blank page to SMART Notebook software?
	4 Why would you change the location of the tabs or toolbar located in the SMART Notebook software?
	5 Why would you use the Attachments tab?

	Hands-on practice: Basics for SMART Notebook software
	1 Launch SMART Notebook by double-clicking the SMART Notebook software icon on the desktop
	2 If the Welcome to Notebook Software window appears, click on New Notebook File
	3 Click in the work area, and type your name. Your name appears in Times New Roman font face, plain style, 16 pt and black color.
	4 Click the Properties tab and then click your name. On the Properties tab click Text Style. Change the font, the size and the font style of your name.
	5 Click Line Style on the Properties tab. Change the color of your name. Click the Save icon on the toolbar. Choose a name for your file, and click Save.
	6 Double-click the Add Page icon on the toolbar to add two more pages to your file
	7 Click the Page Sorter tab. You will see your two new pages. Page three is now the active page, and it is empty. Your name remains on page one. Click the second page.
	8 Click the second page and select the Line icon on the toolbar. Draw a line in the work area.
	9 Click the Properties tab and click the Select icon on the toolbar. Select the line you drew in the work area. It is now the active object on the page.
	10 Click Line Style on the Properties tab. Change the color, thickness, style, start shape and end shape of your line. Click in the work area. Save your SMART Notebook file.
	11 Click the Page Sorter tab and select page three.
	12 Click the Shape icon on the toolbar and select the star shape from the subtoolbar. Draw a star in the work area on page three.
	13 Click the Select icon on the toolbar. Click the Properties tab and select your star. Your star is an active object on the page, and Fill Effects are active on the Properties tab. Change the fill color of your star.
	14 Click Line Style on the Properties tab. Change the color, thickness and style of the line border of your star. Click in the work area. Save your SMART Notebook file.
	15 Click the Select icon on the toolbar and click the Add Page icon to add another page to your file. Click the Page Sorter tab. Page four is now the active page.
	16 Click the Gallery tab. In the Search window, type bean plant, and click the Search icon, which looks like a magnifying glass.
	17 Click Related Folders and click on the Plants folder. Click the arrow on the folder and choose Open.
	18 Click Pictures and Backgrounds. Choose one of the pictures, and drag it to the work area. Your picture is now an active object.
	19 Click the Properties tab, and change the transparency of the picture. Save your file.
	20 Click the Page Sorter tab. Drag page four so it will appear immediately after page one. Save your file.
	21 Share your results with your colleagues. Close SMART Notebook software by clicking File > Exit.
	Objects in SMART Notebook software
	What is an object?


	Manipulating objects in SMART Notebook software
	1 From the menu bar, click Edit > Select All Locked Nodes. The Lock icon will appear on any objects you have locked.
	2 Click the Lock icon
	3 Click Unlock from the menu. Alternatively, right-click an object – the Lock icon will appear with its lock menu. Click Unlock from the menu.

	Shape recognition
	Typed text
	Drawing tools

	Inserting images into SMART Notebook software
	1 Label the rotation handle, the resize handle and the drop-down menu on the object below.
	2 Describe how to move an object from one SMART Notebook page to another.
	3 Why would you add a link to an object that would direct you to another page in your SMART Notebook file?
	4 What is the difference between Send to Back and Send Backward when ordering objects?
	5 How do you spell check within a SMART Notebook file?
	1 Label the rotation handle, the resize handle and the drop-down menu on the object below.
	2 Describe how to move an object from one SMART Notebook page to another.
	3 Why would you add a link to an object that would direct you to another page in your SMART Notebook file?
	4 What is the difference between Send to Back and Send Backward when ordering objects?
	5 How do you spell check within a SMART Notebook file?

	Hands-on practice: Objects in SMART Notebook software
	1 Launch SMART Notebook software by double-clicking on the SMART Notebook software icon on the desktop. Open a new file.
	2 Set your Alignment Guides (Format > Alignment). Click all options to activate them. Click OK. The thin lines appear that mark the horizontal and vertical centers of the page. Page one is the active page. Save your file.
	3 Create a text box that contains your name. From the drop-down menu, click on Infinite Cloner. From the original text box, drag five copies of your name to various locations on the page. Turn off the Infinite Cloner by right-clicking on the original...
	4 Align three of your names by dragging them.
	5 Hold down the left mouse button, and drag to select all three names. Click on one of the drop-down menus, and click Grouping > Group. The three objects are now one.
	6 Click on the drop-down menu, and select Locking > Lock In Place. The object is now locked and cannot be moved. If you want to unlock the object, from the Menu bar click Edit > Select All Locked Nodes. Then click the locked icon and click Unlock. Sa...
	7 Click the Add Page icon to add another page. You are now on the newly created blank page two. Find a graphic from the Gallery, and drag it to your page. Make the graphic larger by dragging on the clear circle. Rotate the graphic by dragging on the ...
	8 Click on the graphic and from the drop-down menu, click Copy. Add a page. From the menu bar, click on Edit > Paste. Click on the graphic, and from the drop-down menu click Flip > Up/Down. Save your file.
	9 Add another page. Click the Text Box icon, and add four text boxes containing the words hellp, bekaus, recieve, and elefant. Click the Select icon, and click one of the words. From the drop-down menu, click Check Spelling. Correct the spelling of y...
	10 Click the Add Page icon to add another page. You are now on the newly created page five. Click the Text Box icon, turn on the spell checker by clicking the icon. Add four text boxes containing the words hellp, bekaus, recieve and elefant. To have ...
	11 Click the Add Page icon to add another page. You are now on the newly created page six. Click the Create Shape icon, and draw four shapes of different sizes. Remember, if you want to draw perfect circles, hold the Shift key down while you are draw...
	12 Share your results with your colleagues. Close SMART Notebook softwareby clicking File > Exit.
	Creating interactive lesson activities
	Where do I start when creating a lesson activity for the SMART Board interactive whiteboard?


	Creating interactive lesson activities
	Review of design basics

	Adding interactivity
	Reveal
	1 Type your question and answer
	2 Draw a rectangle, and fill it with color to hide the answer
	3 Double-click the shape for the ability to add text to it – ensure your text is a different color from the rectangle
	4 Type Move the box to reveal the answer – you are adding instructions to the shape so students, other faculty members or a substitute teacher will be able to work with the file. Without the instructions, others might assume they are supposed to wr...
	5 Move the shape to reveal the answer
	1 Type your question and answer. Use a pen to cover the answer with digital ink.
	2 Click on a pen tool. Choose an ink color the same color as the page background. For example, if the page background is white, then the digital ink should also be white.
	3 Click on the Eraser tool, and erase the digital ink covering the answer. The Eraser tool will only erase objects created with digital ink. Anything typed with your keyboard cannot be erased with the Eraser tool.
	1 Create an object
	2 Create a second, larger solid object
	3 Move the larger object over the smaller object, which will be hidden
	4 When it is time to reveal the smaller object, you can either move the larger object aside or change the order of the larger object to Send to Back
	1 Type your question and answer
	2 Click the Screen Shade button on the SMART Notebook software toolbar
	3 Drag the Screen Shade so only the answer to your question is covered
	4 When you are ready, drag the Screen Shade so it no longer covers the answer. This action is similar to using paper to cover answers that would be displayed through an overhead projector.


	Identify and label
	Drag and drop
	Infinite Cloner
	1 Click an object
	2 Click the object drop-down menu
	3 Click Infinite Cloner
	4 Click the object, then drag to create an identical object

	Magic Pen
	1 What are some ways you can reveal answers to the group?
	2 How would you use the Magic Pen?
	3 How do you access the additional math and science symbols?
	4 How would you use the Infinite Cloner?
	5 Why is font selection important in creating a SMART Notebook file?
	1 What are some ways you can reveal answers to the group?
	2 Why would you use the Magic Pen?
	3 How do you access the additional math and science symbols?
	4 How would you use the Infinite Cloner?
	5 Why is font selection important in creating a SMART Notebook file?


	Hands-on practice: Designing interactive lesson activities
	1 Open a blank SMART Notebook file
	2 Click the Gallery tab to search or browse collections of SMART’s custom pages, clip art, Flash® animations and video files. For this example, you search for flags of North America.
	3 Type the keyword flags
	4 Click the Search icon, which is the large magnifying glass, to initiate your search.
	5 SMART Notebook software displays your search result(s) as a thumbnail image matching your search criteria. In this example, a folder named Flags will appear.
	6 Double-click the folder thumbnail to view its contents
	7 Scroll through the Gallery collection to find flags for the United States, Mexico and Canada. Drag each flag to the work area of your SMART Notebook file. You can double-click the flag’s thumbnail image to quickly add it to your work area.
	8 Resize each flag by diagonally dragging the resize handle. Ensure the flags are approximately the same size.
	9 Align the flags horizontally
	10 Write the name of each country in a different color
	11 Click United States, for example, and choose the appropriate typed text from the object’s drop-down menu. Convert Mexico and Canada from handwritten to typed text also.
	12 Click Clone from the object’s drop-down menu to make a copy of the name of each country. There should be two country names for each flag.
	13 Organize the names of each country so that one set of country names is placed in a vertical line on your work area. Drag the other country names over their corresponding flags.
	14 Click the United States flag, for example, and choose Order > Bring to Front from the object’s drop-down menu to cover the name United States. Complete this task for the Mexican and Canadian flags.
	15 Click File > Save to save your SMART Notebook file. Give your SMART Notebook file a name, and choose the location where you want to save it.
	1 Open your geography lesson
	2 Click on the Gallery tab. By default, the My Content folder is selected.
	3 Click the My Content drop-down menu and choose New Folder
	4 Launch the On-Screen Keyboard and type Country Lesson. You have now created an area where you can store all objects related to your geography lesson.
	5 Drag each flag and country name into your new Gallery collection. Your new Gallery collection now contains nine individual Gallery items – one flag and two names for each country.
	6 Select the Page Sorter tab. Insert a blank SMART Notebook page by clicking the Add Blank Page icon on the SMART Notebook software toolbar.
	7 From the Shapes drop-down menu on the SMART Notebook software toolbar, select the square. Position your cursor on the left side of your work area and draw a large rectangle.
	8 To the right of the rectangle, write or type Languages: and below this write or type English, Spanish, English and French
	9 Press the page thumbnail’s drop-down menu in the Page Sorter tab. Select Add Page to Gallery to place the entire SMART Notebook page into the My Content area of the Gallery Collections. This action gives you quick and easy access to SMART Noteboo...
	10 Drag the Mexican flag from the My Content area to the top-left corner of the rectangle you created in step seven. Then drag the word Mexico to sit directly below the flag.
	11 Drag the Language Exercise page you created in step 10 to the work area of your SMART Notebook file. This action will automatically insert a new SMART Notebook page directly after the active SMART Notebook page.
	12 Repeat steps 11 and 12 using the Canadian and United States flags and associated text
	13 Press File > Save to save your SMART Notebook file
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